Enable jQuery Migrate Helper: плагин для устранения проблем, связанных с jQuery в WordPress 5.5

Enable jQuery Migrate Helper: плагин для устранения проблем, связанных с jQuery в WordPress 5.5 1

С момента выхода WordPress 5.5 прошло не так много времени, однако пользователи уже стали отмечать неполадки в работе своих сайтов. Именно по этим причинам новый плагин Enable jQuery Migrate Helper смог набрать 10к активных установок. Плагин был создан командой WordPress Core для устранения проблем, связанных с jQuery, с которыми пользователи могут столкнуться после обновления WordPress до версии 5.5. Как известно, в WordPress 5.5 был удален скрипт jQuery Migrate 1.4.1, и в результате этого темы и плагины, полагающиеся на устаревшие функции jQuery, перестали функционировать.

Официальные форумы поддержки наводнились сообщениями о неисправных сайтах после обновления до 5.5. Большинство пользователей, которые не следили за разработкой ядра, не знали, что скрипт jQuery Migrate теперь признан устаревшим. В итоге на многих сайтах отмечались проблемы с функциональностью – пользователи, к примеру, не могли редактировать и просматривать контент. Сильнее всего пострадали те, кто использовал классический редактор, поскольку старые плагины, привязанные к нему, чаще всего полагались на устаревшие функции jQuery.

Плагин Enable jQuery Migrate Helper имеет много отзывов с оценкой 5, поскольку он мгновенно решает большинство пользовательских проблем.

С помощью этого плагина можно выяснить, какие темы и плагины приводят к неполадкам, и попросить их авторов доработать свои продукты для совместимости с последней версией WordPress.

Плагин способен существенно сэкономить деньги пользователей, поскольку в противном случае людям пришлось бы обращаться к фрилансерам за помощью.

Джастин Тэдлок на прошлой неделе опубликовал пост, в котором раскрыл трехэтапный план WordPress по обновлению jQuery до последней версии. В плане указано, что в WordPress 5.6 появится новая версия jQuery Migrate, чтобы пользователи могли обновиться с  jQuery 1.12.4 до 3.5.1 (или выше). Скрипт будет повторно удален в релизе WordPress 5.7, который должен выйти в 2021 году.

Плагин Enable jQuery Migrate Helper – временное решение. Как известно, в WordPress 5.6 должно появиться автоматическое обновление главных версий WP, потому важно, чтобы сопутствующие компоненты, такие как jQuery, тоже своевременно обновлялись.

Понравилась статья? Поделиться с друзьями:
Блог про WordPress
Мы используем cookie-файлы для наилучшего представления нашего сайта. Продолжая использовать этот сайт, вы соглашаетесь с использованием cookie-файлов.
Принять
Отказаться
Политика конфиденциальности